Jump to content
CarPort ForumCarPort Forum
Gerrit van Niekerk

ELM327 and K-Line

Recommended Posts

Best CarPort people,

 

I'm trying to get CarPort to talk to my VW Polo Vivo (a South African polo 9N).

 

According to the StartTab, Carport finds the interface ( ELM 327 v1.5) and happily talks with it. The top-row boxes are all ticked in green, but on the second (Volkswagen) line, I have two red crosses...

 

I decided to take a look with USBPCap (USB add-on for wireshark), and I think I know where it goes wrong:

CarPort goes through a fairly long protocol programming sequence (eg atpbc0 01, atpp19svff, atpp19on, etc.) to which the ELM keeps on replying OK.

 

CarPort then writes 'stdi' to which the ELM just replies: '?'. I would assume this 'stdi' should be written to the CAN but ELM just decided it is meant for it and doesn't understand it? (I must confess I have no experience with these car 'modem' protocols ;) )

 

Anyway, after that, CarPort writes atppi to which ELM dumps a very long summary. After that CarPort just switches off the protocol (atpc) and doesn't try again; just start writing 'ati' every second or so...

 

So I reckon the problem is that ELM handles the 'stdi' incorrectly? Is there any workaround for this?

I can also send you the wireshark file if it would help.

 

Kind regards,

Gerrit

 

Share this post


Link to post
Share on other sites

Just an update: I've downloaded the ELM327 Data Sheet and noticed that only hexadecimal ascii characters should be sent to the Bus. Meaning the STDI was meant for the ELM, but it is an 'undocumented' command. (I've also noticed reference to it on the internet).

 

So the question is, why does CarPort give up when the ELM can't answer the STDI? CarPort doesn't even try to query the bus (with a 0010 or similar). And of course, is there a way to get around it? Some setting to 'not use stdi command'? :)

 

Thanks in advance

Gerrit

 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.